О программе

"Что? Где? Когда? - Автоматизация игр"

версия 0.5

http://igra-krasnodar.narod.ru

Если Вы читаете данный текст, это означает, что Вы являетесь счастливым обладателем чудесной программы "Что? Где? Когда? - Автоматизация игр".

Эта программа предназначена для ускорения процесса подсчёта сданных командами ответов при игре в "Что? Где? Когда?"


Дополнительные функции

В находящемся прямо под потолком экрана меню продублированы функции описанных выше кнопок. Но там есть и кое-что новенькое. В меню "Файл" вы сможете экспортировать результаты вашей игры в бессмертные программы фирмы Билла Гейтса: "Microsoft Word" и "Microsoft Excel" (зарегистрированные торговые знаки). Согласитесь, что распечатанная из "Экселя" табличка приятно порадует игроков и болельщиков. Также вы сможете сохранить результаты игры уже в виде соответствующего "эксельного" или "вордовского" файла. Надеюсь, вы знаете, как сохраняются документы в формате doc или xls...

В меню "Настройка" можно настроить ширину и высоту ячеек, шрифт расположенного в них текста, цвета всего операторского поля ("Интерфейс"), а также задать пароль для входа в данную программу.

Через пункт меню "Настройка" - "Интерфейс" можно менять цветовую схему программы. В появившемся окне для изменения цвета нужно дважды щелкнуть по его названию и выбрать нужный цвет. Изменения цвета сохраняются автоматически.


Об авторах

Программа "Что? Где? Когда? - Автоматизация игр" задумана и воплощена в жизнь кубанским программистом Терешенковым Александром Владимировичем ( e-mail:tereshenkov@mail.ru ) в начале апреля 2005 года

А бета-тестирование и написание почти всех справочных текстов к программе осуществил Бондаренко Александр Евгеньевич ( e-mail:bondarenko@narod.ru ), вовсе не являющийся программистом... Так что если найдёте какие-то косяки - это он не доглядел :-)

Да будет известно широкой публике, что А. Е. Бондаренко является капитаном, а А. В. Терешенков - игроком известной в узких кругах краснодарской интеллектуальной команды "Чёрная Дыра", об истории и традициях которой вы можете узнать на web-ресурсах http://www.bondarenko.narod.ru/dyrka.html или http://www.roman-shevchuk.narod.ru/black_hole/black_hole_index.html

Программа "Что? Где? Когда? - Автоматизация игр" создавалась на голом энтузиазме. Планировалось распространять её абсолютно бесплатно. Всем желающим получить программу будет торжественно вручён компакт-диск с программой, инструкция пользователя и в устной форме передана благодарность от имени авторов. Незаконное копирование и распространение данной программы без ведома автора вовсе не будет преследоваться засланными авторами киллерами с гранатомётами :-) Копируйте, но желательно с ведома автора.

Последнюю версию программы, а также документацию к ней можно загрузить с сайта http://igra-krasnodar.narod.ru. На сайте Вы можете оставить в гостевой свое мнение, комментарии и пожелания к программе. Доступен постоянно обновляемый ЧАВО (частые вопросы с ответами на них).

А происходило всё это в наверное уже далёком для вас апреле две тысячи пятого года...


Основные функции

После всех этих утомительных манипуляций вы должны попасть в главное окно программы. Оно представляет таблицу, где вверху указаны названия играющих команд, а слева - номера вопросов. Нажав на ячейку соответствующего вопроса в столбце "Установка правки", вы сможете проставлять правильные ответы на этот вопрос играющим командам. Производится это двойным щелчком мыши на клеточке соответствующей команды. Обратите внимание, что при этом в данной ячейке появляется цифра, отображающая количество баллов, заработанное этой командой. По принятым в г. Краснодаре правилам количество набранных давшими правильные ответы командами баллов за один вопрос равняется количеству неправильных ответов на этот же вопрос. Приведём простой пример. Если в турнире играют 10 команд и при этом на первый вопрос правильно ответили семь команд, то они получают по три балла (так как три команды на вопрос не ответили). Однако вы в любой момент можете изменить данную схему подсчёта баллов, отправившись в пункт меню "Настройка", далее - "Правила подсчёта очков и мест". В левой половине появившегося диалогового окна по умолчанию выбрана уже описанная выше схема подсчёта ("Число минусов"). Если вы выберете "Число минусов плюс один", то в описанном примере с десятью командами семь правильно ответивших команд получат по четыре балла. Если же вас тошнит от сложных подсчётов, то можете смело выбирать пункт "Единичка", означающий один балл за один правильный ответ.

Правое поле диалогового окна "Правила подсчёта очков и мест" гораздо сложнее для восприятия, чем описанная ранее левая половинка. Но не падайте духом! Сейчас мы вам всё объясним. При выборе расчёта мест "только по ответам" количество набранных по любой схеме баллов просто не будет учитываться. Занятые командами места будут определяться по самой простой схеме - в зависимости от числа правильных ответов. При расчёте мест "только по баллам" будет происходить обратное: число правильных ответов уже не столь важно, главное - количество набранных при этом баллов. Здесь возможна ситуация, когда команда с десятью правильными ответами и 95 баллами уступит первое место команде с 8 правильными ответами, но 123 баллами. Пункт "При равенстве баллов - по ответам" означает, что при равном количестве набранных какими-либо командами баллов результат будет зависеть от числа их правильных ответов. Пункт "При равенстве ответов - по баллам" значит, что в случае одинакового числа набранных командами ответов вперёд пойдёт та команда, у которой больше баллов.

При подсчёте ответов на каждый следующий вопрос вам необходимо щёлкнуть в ячейке данного вопроса в столбце "Установка правки". Строка с активизированным вопросом тут же подсветится другим цветом. Это сделано для того, чтобы избежать ошибок при случайных щелчках мышью.

При постепенном заполнении таблицы результатами игры вы заметите, как соответствующим образом изменяются показатели в нижней части экрана. Там отображено количество правильных ответов, сумма очков (баллов) и соответствующее место каждой команды. Данные цифры динамически обновляются "на лету", чем существенно облегчён процесс подсчёта результатов игры.

Нажав на расположенную недалеко от слова "Управление" стрелочку, вы можете скрыть или отобразить панель управления с "горячими" кнопками.

Кнопка "Вкл./искл. вопрос" позволяет заблокировать результаты любого вопроса или же разблокировать его. Это необходимо, если вопрос по каким-либо причинам снимается или если его результаты пока не идут в общий зачёт. Например, в принятой в г. Краснодаре схеме игры результаты нулевого и тринадцатого вопросов каждого тура не засчитываются до того момента, пока на один из "обычных" вопросов не поступит вообще ни одного правильного ответа или же, наоборот, все команды дадут правильный ответ. Но вы можете благодаря этой кнопке вручную выбирать вопросы, которые нуждаются в блокировке. Помните, что результаты заблокированного вопроса не учитываются при подсчёте очков.

При нажатии на кнопку "Настройка ячеек" вы сможете изменить ширину и высоту ячеек таблицы. Изначально ширина столбцов заложена довольно узкая - в расчёте на большое количество играющих команд... Но если в вашей игре задействован всего десяток команд или же вы запустили эту программу на мониторе с диагональю 22 дюйма, то тогда смело можете расширять ячейки сантиметров до трёх.

В процессе игры вы всегда можете добавить новую команду с помощью кнопки "Добавить команду". Это сделано специально для любителей опаздывать на игру. Попытки добавить команду без названия обречены на провал, можете даже не пытаться. Пользуясь расположенным в меню "Управление" пунктом "Удалить команду", вы можете в любой момент ликвидировать команду, чей столбец перед этим выделите.

Благодаря чудесной кнопке "Шрифт ячеек" вы можете изменять сам шрифт, его начертание, размер и прочие характеристики. Захотите "Times New Roman" жирный курсив 12-го размера - пожалуйста! Захотите что-то другое - тоже без проблем.

При нажатии на кнопку "Сохранить" происходит служебное сохранение файла. Как и куда он сохраняется, не важно. Главное, что сохраняется.

Кнопка "Вкл./выкл. спорный ответ", в общем-то, ни на что не влияет... Просто когда вы выделяете какой-то ответ какой-то команды и желаете пометить его для себя на потом как спорный, данная кнопка подсветит его другим цветом, чтобы по окончании игры вам легко было найти данный ответ.

В меню "Управление" есть чудная кнопка "Отчёт", нажав на которую, вы попадёте в отчёт об игре: простейшая схемка с распределением команд по занятым ими местам. Приятна на глаз и на ощупь (если её распечатать, естественно). Если вы захотите узнать среднее арифметическое по ответам и баллам игравших команд, поставьте соответствующую галочку напротив пункта "Вывести средние значения".

Также в меню "Управление" есть функции сортировки названий команд по возрастанию и убыванию. При этом используется алфавитный порядок расположения названий команд. При большом количестве команд данная функция весьма удобно расположит все их названия в нужном порядке.

Через меню "Помощь" вы можете попасть в три раздела. В "Содержании" вы прочитаете тот самый текст, который сейчас находится перед вашими глазами. В разделе "О программе" можно ознакомиться с авторскими правами и номером используемой вами версии продукта (не забывайте вовремя обновлять программу!). В разделе "Об авторах" вы прочитаете о главном и единственном авторе данной программы - Александре Терешенкове, чьими трудами мы и обязаны существованию данного бесценного продукта компьютерной мысли. Также в этом разделе будет небольшое упоминание о главном и единственном бета-тестере программы - Александре Бондаренко, который вот прямо сейчас (без двадцати два часа ночи пятого апреля 2005 года) сидит за компьютером и набивает эту дурацкую инструкцию...

В общем, надеемся, что вам понравится программа "Что? Где? Когда? - Автоматизация игр" так же, как она понравилась её авторам.


Создание игры

После установки программы на рабочем столе и/или на панели быстрого запуска (в зависимости от вашего выбора при установке программы) появится ярлычок. На него следует нажать курсором мышки. Если вы запустили программу первый раз, появится сообщение о создании пустой базы данных игр. Нажмите "ОК". В появившемся окне со списком игр нажмите "Добавить". Вам будет предложено ввести название игры. Добавив название игры, нажмите на кнопку "Открыть игру". Далее вам следует ввести в левой части диалогового окна названия играющих команд. Не забывайте одно простое правило: одна строка отведена под название одной команды. При этом вы можете использовать латинский и кириллический шрифты, кавычки, маленькие и большие буквы, а также любые числа. Если какие-то команды не были введены на этом этапе, это можно будет сделать позже.

В правой части этого же диалогового окна вам необходимо ввести настройки количества туров, вопросов в туре и номер первого вопроса. По принятой в г. Краснодаре классической схеме обычная игра состоит из двух туров по четырнадцать вопросов (из них нулевой и тринадцатый изначально не идут в зачёт). Нулевой и тринадцатый вопросы идут в зачёт в том случае, если на какой-либо из основных вопросов не поступило ни одного правильного ответа или если на него правильно ответили все команды. Впрочем, вы можете задать произвольное количество туров и вопросов - в зависимости от привычной вам схемы проведения игр. Если вы поставите галочку напротив фразы "Сквозная нумерация", это означает, что вопросы в каждом новом туре игры будут нумероваться не с единицы (или нуля), а продолжат нумерацию предыдущего тура.

По завершении ввода команд и настройки туров/вопросов нажмите "ОК"


Установка и системные требования

Программа ""Что? Где? Когда? - Автоматизация игр"" предназначена для использования на компьютерах IBM PC или полностью совместимых с ними.

Для качественной работы программы не рекомендуется использовать компьютеры с тактовой частотой процессора ниже 400 МГц и оперативной памятью менее 64 Мб.
Рекомендуемое разрешение экрана - не ниже 800x600, рекомендуемая цветовая палитра - high color, 16 байт.

Программа может быть установлена на любом компьютере, на котором установлена операционная система Windows 95, Windows 98, Windows Me, Windows NT, Windows 2000, Windows XP, Windows 2003. Для экспорта данных в Microsoft Excel и Microsoft Word необходимо наличие этих программ.

Для базовой установки программы необходимо дисковое пространство 5 мегабайт.

Установочный диск должен запуститься сам через непродолжительное время после засовывания в CD-привод. Если же этого не произошло, значит, вам надо запустить вручную с данного диска файл autostart.exe (например, через "Проводник"). Если же и после этого ничего не запустилось, тогда надо запустить находящийся на диске файл igra_setup.exe. Если не повезло и на этот раз (ничего не произошло), тогда не судьба...

После успешного запуска установочной программы надо ответить "Да" на вопрос о подтверждении установки. Дальше предлагается выбрать каталог для установки и компоненты программы. Для правильной установки все компоненты должны быть помечены галочками. Не меняйте тип установки!

В следующем диалоговом окне можно отметить создание ярлыков к программе на рабочем столе и панели быстрого запуска. Если ярлыки вам не нужны, просто снимите нужные галочки.

В случае успешной установки должно появиться сообщение "Программа "Что? Где? Когда?" успешно установлена"